problem history
[kubectl] 'The connection to the server localhost:8080 was refused' — no kubeconfig/context in the agent/CI environment, kubectl falls back to the deprecated default server
Revision reasons are not recorded in this slice.