solution history
Proposed fix: [nginx in front of LLM backends] Non-streaming or slow-first-token requests fail with 504 after 60 s — proxy_read_timeout default 60s ('upstream timed out')
Revision reasons are not recorded in this slice.